OpenRoads Designer CONNECT Edition SDK Help

StrokeByStep(Double, StrokingByStepMethod, Double) Method

Strokes linear element by step.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointCollection StrokeByStep(double stepValue, StrokingByStepMethod stepMethod,double ptToPtTolerance)

Parameters

SettingDescription
   Incremental/equal step distance.
  StrokingByStepMethod Stroking by step method.
   Point to point tolerance between points of the resulting collection.

Return Value

LinearPointCollection Collection of stroked points.

See Also